Instalace php-5.2 a vyšší

Na VPS je instalován CentOS 5. Podle oficiálních zdrojů je pro tuto distribuci k dispozici pouze verze 5.1.x. V oficiálních repozitářích php 5.2.x neni. Řešení je několik.
  1. nainstalovat yum (například podle tohoto návodu), najít repozitář s požadovanou verzí php provést update. Lze použít

    repozitář Atomicorp (php 5.4): http://www2.atomicorp.com/channels/atomic/centos/. Postupujte podle návodu na stránkách, kam vede odkaz.


  2. Pokud nechcete instalovat yum, stačí nainstalovat balíčky z archivů php-5.2.9.zip nebo php-5.2.10.zip (jde o zip archiv obsahující již připravené rpm balíčky příslušné verze php). Akce se provádějí po přihlášení k serveru přes SSH

    Postup je následující
    :
    - uložit archiv na VPS
    - rozbalit archiv do libovolného adresáře
        unzip php-5.2.9.zip
      nebo
        unzip php-5.2.10.zip
    - za pomoci rpm -Uvh ./*.rpm v adresáři kam byl archiv rozbalen aktualizovat php na verzi 5.2.9 (obsahuje moduly mssql) respektive 5.2.10 (mssql moduly nebyly v době psaní příspěvku pro tuto verzi dostupné)
    - není-li v systému balík libmcrypt, stačí nainstalovat libmcrypt-2.5.8-4.el5.centos.i386.rpm z repozitáře CentOS extras

POZOR: použití repozitáře testing + balíčků stažených z této stránky (pocházejí z toho samého repozitáře) je na vlastní nebezpečí a důrazně doporučujeme provést zálohu.

Před aktualizací na php 5.3 a výšší doporučujeme prověřit, zda jsou Vaše webové aplikace na tuto verzi připravené !!!!



obsah archivů v příloze:

php-5.2.9.zip
 freetds-0.82-0.el5.centos.i386.rpm
 php-5.2.9-2.el5.centos.i386.rpm
 php-bcmath-5.2.9-2.el5.centos.i386.rpm
 php-cli-5.2.9-2.el5.centos.i386.rpm
 php-common-5.2.9-2.el5.centos.i386.rpm
 php-dba-5.2.9-2.el5.centos.i386.rpm
 php-devel-5.2.9-2.el5.centos.i386.rpm
 php-gd-5.2.9-2.el5.centos.i386.rpm
 php-imap-5.2.9-2.el5.centos.i386.rpm
 php-ldap-5.2.9-2.el5.centos.i386.rpm
 php-mbstring-5.2.9-2.el5.centos.i386.rpm
 php-mcrypt-5.2.9-2.el5.centos.3.i386.rpm
 php-mssql-5.2.9-2.el5.centos.3.i386.rpm
 php-mysql-5.2.9-2.el5.centos.i386.rpm
 php-ncurses-5.2.9-2.el5.centos.i386.rpm
 php-odbc-5.2.9-2.el5.centos.i386.rpm
 php-pdo-5.2.9-2.el5.centos.i386.rpm
 php-pgsql-5.2.9-2.el5.centos.i386.rpm
 php-snmp-5.2.9-2.el5.centos.i386.rpm
 php-soap-5.2.9-2.el5.centos.i386.rpm
 php-xml-5.2.9-2.el5.centos.i386.rpm
 php-xmlrpc-5.2.9-2.el5.centos.i386.rpm


php-5.2.10.zip
 php-5.2.10-1.el5.centos.i386.rpm
 php-bcmath-5.2.10-1.el5.centos.i386.rpm
 php-cli-5.2.10-1.el5.centos.i386.rpm
 php-common-5.2.10-1.el5.centos.i386.rpm
 php-dba-5.2.10-1.el5.centos.i386.rpm
 php-devel-5.2.10-1.el5.centos.i386.rpm
 php-gd-5.2.10-1.el5.centos.i386.rpm
 php-imap-5.2.10-1.el5.centos.i386.rpm
 php-ldap-5.2.10-1.el5.centos.i386.rpm
 php-mbstring-5.2.10-1.el5.centos.i386.rpm
 php-mysql-5.2.10-1.el5.centos.i386.rpm
 php-ncurses-5.2.10-1.el5.centos.i386.rpm
 php-odbc-5.2.10-1.el5.centos.i386.rpm
 php-pdo-5.2.10-1.el5.centos.i386.rpm
 php-pgsql-5.2.10-1.el5.centos.i386.rpm
 php-snmp-5.2.10-1.el5.centos.i386.rpm
 php-soap-5.2.10-1.el5.centos.i386.rpm
 php-xml-5.2.10-1.el5.centos.i386.rpm
 php-xmlrpc-5.2.10-1.el5.centos.i386.rpm