Aktualizace jádra Plesku

Parallels (dodavatel Plesku) pravidelně vydává drobné dílčí aktualizace pro každou verzi. Opravují chyby jako například v příspěvku Oprava chyby logwatch v Plesku

Doporučujeme průběžně kontrolovat, zda není taková aktualizace k dispozici:


1. v příkazové řádce:
[root@localhost ~]# /usr/local/psa/admin/sbin/autoinstaller --select-product-id plesk --select-release-current --reinstall-patch --install-component base
selže-li aktualizace na následující chybě (unrecognized option `--reinstall-patch)
[root@localhost ~]# /usr/local/psa/admin/sbin/autoinstaller --select-product-id plesk --select-release-current --reinstall-patch --install-component base
/usr/local/psa/admin/sbin/autoinstaller: unrecognized option `--reinstall-patch'
ERROR: You specified an unknown option.
Not all packages were installed.
máte zastaralou verzi instaátoru a je ho zaktualizovat. Verze autoinstalleru umožňující reinstalovat všechny patche je  psa-autoinstaller-3.6.x. (verze 3.6 a vyšší).  Zjistí se příkazem
[root@localhost ~]# rpm -qa | grep psa-autoinstaller
psa-autoinstaller-3.6.1-110415.10
Pokud je instalovaná verze psa-autoinstaller-3.3.2, aktualizujeme z repozitáře Parallels
[root@localhost ~]# rpm -Uvh http://autoinstall.plesk.com/PSA_8.6.0/dist-rpm-CentOS-5-i386/opt/updater/psa-autoinstaller-3.6.1-110415.10.i386.rpm
Retrieving http://autoinstall.plesk.com/PSA_8.6.0/dist-rpm-CentOS-5-i386/opt/updater/psa-autoinstaller-3.6.1-110415.10.i386.rpm
Preparing... ########################################### [100%]
1:psa-autoinstaller ########################################### [100%]
pak již aktualizace jádra Plesku + reinstalace všech dostupných patchů projde.

2. v grafickém rozhraní

po přihlášení do Plesku v levém menu klikněte na Server:

v hlavním rámci >> Updater:

vyberte Vámi používanou verzi Plesku, a v seznamu dostupných balíčků je "Base packages of Plesk".

V případě, že u tohoto balíčku není zelený symbol (= aktuální stav), doporučujeme ho zaškrtnout a kliknutím na odkaz "Install" provést aktualizaci. Můžete zaškrtnout i další nabízené balíčky. Před instalcí ale prověřtem zda má Váš server dostatek volného místa - vyčerpání diskové quoty v průběhu instalace způsobí nefunkčnost aktualizovaných komponent plesku. 

POZOR: Před aktualizací na vyšší verzi Plesku si přečtěte příslušný příspěvek: Aktualizace Plesku